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WEEK One (practical) 

Learning Outcome 

  

Student should be able to use at least two browsers to connect to 

the internet, browse the internet and explore basic internet 
applications especially the World Wide Web. 

 

Lab1: Use the Internet Explorer (IE) to log on to the 
net. 

 

Steps: 

1. Make sure your system has internet connection. 

2. Double-Click internet explorer if the icon is found on the 

desktop         or locate it from the program on the start 

button and click.  

3. If No internet connection, a page like below would be 
displayed 
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4. If there is connection, the default web page will be displayed 
like the yahoo page below. (to set default page, Click tools 

from the web page tool bar, click internet option, then type in 

the address of he your choice internet web page) 
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WEEK Two (practical) 

Learning Outcome 

  

Student should be able to load a text editor, enter some html tags, 

save and use a browser to execute  
 

Lab1: :Load Note and enters html tags to 

demonstrate your first web page tags. 

 

 

Steps: 

5. To load Notepad, open all programs and click accessories 

6. Click note pad and the pad editor will be displayed as below 

 

7. To allow for text wrapping, go to Format menu and put a 

check mark by Word Wrap. This keeps your text from 

appearing as one long line that you'd have to scroll sideways 

to see as below 
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8. Enter the relevant tags and save it “Mypage.html” to appear 

as below. (Note that it is a wise idea to create a folder for all 

your html and sample web design files. Call it WEBfolder and 

place it on the Desktop for this practical purpose.) 

 

 

 

 

 

 

 

 

 

 

 

 

 

Lab2: Use internet explorer to execute the codes. 

 

Steps: 

1. Start internet explorer 
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2. Click file menu and click Open or from the explorer page click 

CTRL+O. 

3. An open dialog box will appear as below, browse to locate 

your html file “Mypage” from our created WEBfolder on the 

desktop. 

 

4. Click Ok and Ok again in case of any other notification 

message after. 

5. The web page will be displayed as below 
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6. To edit a page just go back to notepad and open your html file 

edit and re-save 

How? 

- On your Notepad Click Open 

- Locate your folder on the file open dialog 

- Change Document type to All files from Text Document 

(.txt) displayed on the dialog 

 

- Your html file mypage appears, select and click OK 

- The document is loaded to make all changes and save back 

7.  To view the changes, right click your displayed webpage and 

click refresh. 
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WEEK Three (practical) 

Learning Outcome 

  

Students should know and implement Text formatting, text 

alignment, fonts and html elements such as header paragraphs, 

breaking etc.  

 

Lab1: : Demonstrate the Heading and Paragraph tags by 
including them in “Mypage” that we designed in Week 

two. 

 

 

Practice 
Let us add the followings to the body tag   

<h1>This is the Main heading</h1> 
<h2>This is the Sub heading</h2> 
<p> Its fun to know the basics of webpage and to have 
used the little I have learnt to create a simple but 
fascinating web page.  
</p> 
<p> Thanks to all that have contributed in one way or 
the other for the development of this material. 
</p> 

It should look as below in the editor 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
When run on the browser it appear as below 
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Lab2: : Demonstrate the Attribute Values 
 

 

Practice 
 

We may demonstrate the Attribute Values by reformatting our 

project i.e. “Mypage” as follows. 
     <h1 Align = “Center” >This is the Main heading</h1> 

<h2>This is the Sub heading</h2> 

<p bgcolor="yellow"> Its fun to know the basics of webpage and to have 
used the little I have learnt to create a simple but fascinating web page.  

</p> 

<p> Thanks to all that have contributed in one way or the other for the 

development of this material. 

</p> 
It should look as below in the editor 
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When run on the browser it appear as below 

 
 

 

 

 

 

 

Text Alignments 
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WEEK Four(practical) 

Learning Outcome 
  
Students should know how to create link to a web page or another 

html file, understands the basics of listing.  

 

Lab1: : Adding a Link to yahoo page to our “Mypage” 
page. 

 

 

Practice 
 
Let us add the followings to the body tag   
 

<a href="http://www.yahoo.com/">Visit Yahoo Site!</a> 
  

 
When our webpage is refreshed it should look like this 
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Lab1: : Adding a the following numbered list to the body 
tag of  “Mypage” page. 

 

 

Practice 
 

<body> 

…… 

…… 

<ol type="A"> 

<li>List Item 1 

<li>List Item 2 

<li>List Item 3 
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<li>List Item 4 

</ol> 

 

</body> 

</html> 

When our webpage is refreshed it should look like this 
 

 
 Note that the background has been changed to 

“orange” color. 
 

The entire html code is as below 

 
<html> 

<head> 

<title>My First Web Page</title> 

</head> 

<body bgcolor="orange"> 

<h1 Align="Center">This is the Main heading</h1> 

<h2>This is the Sub heading</h2> 

<p> Its fun to know the basics of webpage and to have  

 

used the little I have learnt to create a simple but  
 

fascinating web page.  

</p> 
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<p> Thanks to all that have contributed in one way or  
 

the other for the development of this material. 

</p> 
<a href="http://www.yahoo.com/">Visit Yahoo Site!</a> 

<br><br> 

<b><u> LIST OF ITEMS </U></b> 

<ol type="A"> 

<li>List Item 1 

<li>List Item 2 

<li>List Item 3 

<li>List Item 4 

</ol> 

 
 

</body> 

</html> 
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WEEK Five(practical) 

Learning Outcome 

  

Students should know how to add images to web pages and change 

either background or text colors using the available colors schemes.  
 

Lab1: : Adding an image (NBTE) logo to “Mypage” page. 
 

 

Practice 
 
You have to be sure that the NBTE logo is scanned and saved into 

the appropriate folder where it can be loaded from such as the 

WEBfolder and then add the following code to the body tag   

 

<img src=" <img 

src="c:\Users\Deen\Desktop\WEBfolder\NBTE.jpg" width="200" 

height="100"> 
  

 

When our webpage is refreshed it should look like this 
 
 

 
 
 
 
The Code is as below 
<html> 
<head> 
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<title>My First Web Page</title> 
</head> 
<body bgcolor="orange"> 
<h1 Align="Center">This is the Main heading</h1> 
<h2>This is the Sub heading</h2> 
<p> Its fun to know the basics of webpage and to have  
 
used the little I have learnt to create a simple but  
 
fascinating web page.  
</p> 
<p> Thanks to all that have contributed in one way or  
 
the other for the development of this material. 
</p> 
<a href="http://www.yahoo.com/">Visit Yahoo Site!</a> 
<br><br> 
<b><u> LIST OF ITEMS </U></b> 
<ol type="A"> 
<li>List Item 1 
<li>List Item 2 
<li>List Item 3 
<li>List Item 4 
</ol> 
 
<img src="c:\Users\Deen\Desktop\WEBfolder\NBTE.jpg" width="200" 
height="100"> 
 
 
</body> 
</html> 
 
 
 
 
 

Lab2: : Adding an image (UNESCO) as a Background 
image  to a new webpage called “Mypage2” page. 
  

Practice 
To display the Background in the sample, create fresh file named 

“Mypage2.html” containing the following codes. 
 
 <html> 
<body background="C:\Users\Deen\Desktop\WebPageFolder\unesco.jpg"> 
</body> 
</html> 
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When webpage1 is loaded it should look like this 
 

 
 
 

The Main page after “unesco” background is  inserted 
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WEEK Six (practical) 

Learning Outcome 

  
Students should know how to create form and add fields as well as 

buttons.  

 

Lab1: : Create an Input form collecting some input fields, 
radio button, check box, command button and reset 
button. 

 

 

Practice 
Create a sample page called “MypageForm” and include the 

following code. 
<html> 
<head> 
<title>My Input Form</title> 
</head> 
<body bgcolor="orange"> 
<img src="c:\Users\Deen\Desktop\WebpageFolder\NBTE.jpg" width="70" height="70"> 
<p>   
<font size="12pt" face="arial" color="Blue"> 
<b><u> Data Collection </U></b> 
</font> 
 
<form> 
<b> Enter Names </b> 
<br> 
First name:  
<input type="text" name="firstname"> 
<br> 
Last name:  
<input type="text" name="lastname"> 
<br> 
<b> 
Sex: 
</b> 
<input type="radio" name="sex" value="male"> Male 
 
<input type="radio" name="sex" value="female"> Female 
 
 
<br> 
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<b> 
Schools Attended: 
</b> 
<br> 
Primary School: 
<input type="checkbox" name="School" value="Primary"> 
<br> 
Secondary school:  
<input type="checkbox" name="school" value="secondary"> 
<br> 
Higher Institution:  
<input type="checkbox" name="school" value="Tartiary"> 
</p> 
 
<b> 
Favorite Polytechnic: 
</b> 
 
<select name="favorite Poly"> 
<option selected value="kpt">Kaduna Polytechnic 
<option value="aupoly">Auchi Poly 
<option value="baupoly">Bauchi Poly 
<option value="yaba">Yaba Tech 
</select> 
<br> 
 
<b> 
Write little comments about yourself: 
</b><br> 
<textarea name="words" cols="20" rows="5"> 
Start here... 
</textarea> 
<br> 
 
<input type="reset" value="Reset"> 
<input type="submit" value="Submit"> 
</select> 
 
 
</form> 
 
</body> 
</html> 
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When our Mypageform is loaded it should look like this 
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WEEK Seven (practical) 

Learning Outcome 

  
Students should know how to create form and add fields as well as 

buttons.  

 

Lab1: : Create a webpage that divide into two main page 
frames of unequal size. Each of the frame is an already 
developed paged saved in our common folder 

 

Practice 
We may demonstrate frame tag by creating an additional page 
named “Mypageframe.html” that serves as the main web page. It 

should be divided into two columns of 25% and 75% respectively. 

The first frame should connect the “Mypage.html” and the second 

should connect to “MypageForm.html”. 

 

The “mypageframe.html” should contain the following code 

 
<html> 
<head> 
<title>Main Page</title> 
</head> 
 
<frameset cols="25%,75%"> 
   <frame src="C:\Users\Deen\Desktop\WebPageFolder\Mypage.html"> 
   <frame src="C:\Users\Deen\Desktop\WebPageFolder\Mypageform.html"> 
 
</frameset> 
 
</html> 
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When the MypageFrame is loaded it should look like this 
 

 
 

 

 

Lab2: : Remove the Paragraph element from Mypage and 
add a table of rows and columns. 

 

Practice 
The MyPage.html code should now look like this after the 
paragraphs are modified. 

 

<html> 

<head> 

<title>My First Web Page</title> 

</head> 
<body bgcolor="orange"> 

<img src="c:\Users\Deen\Desktop\WebpageFolder\Unesco.jpg" 

width="100"  
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height="100"> 
 

<h1 Align="Center">This is a table</h1> 

<h2>Contains 2rows and 2cols</h2> 
<p> <table border="1"> 

<tr> 

<th>Heading</th> 

<th>Another Heading</th> 

</tr> 

<tr> 

<td>row 1, cell 1</td> 

<td>row 1, cell 2</td> 

</tr> 

<tr> 
<td>row 2, cell 1</td> 

<td>row 2, cell 2</td> 

</tr> 

</table> 

 

</p> 

<a href="http://www.yahoo.com/">Visit Yahoo Site!</a> 
<br><br> 

<b><u> LIST OF ITEMS </U></b> 

<ol type="A"> 

<li>List Item 1 
<li>List Item 2 

<li>List Item 3 

<li>List Item 4 

</ol> 

 

 

</body> 

</html> 
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When the MypageFrame is loaded it should look like this 
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WEEK Eight (practical) 

Learning Outcome 

  
Students should know how to create CSS and insert to their web 

documents either externally or internally.  

 

Lab1: : Create an internal style sheet and add to 
document internally 

 

Practice 

An internal style sheet should be used when a single document has 

a unique style. You define internal styles in the head section by 

using the <style> tag, like this: Save the file as MypageCSS.html. 

 
<html> 
<head> 
<style type="text/css"> 
hr {color: sienna} 
h1  
{ 
text-align: right;  
font-size: 20pt; 
color: blue 
} 
 
p {margin-left: 40px} 
body  
{color: white; 
Font-size:20pt 
} 
</style> 
</head> 
 
<body bgcolor="tan"> 
<h1> 
This is for CSS 
</h1> 
<p> 
Hello 
</p> 
</body> 
</html> 
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When the MypageCss is loaded it should look like this 
 

 
 

Lab2: : Create an external style sheet and embed it to 
your web file and run 
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WEEK Nine (practical) 

Learning Outcome 

  
Students should know how to modify CSS files; changing fonts, 

padding, listing, merging, tables, borders etc.  

 

Lab1: : Create an image gallery using CSS 
 

Practice 
 
 

CSS can be used to create an image gallery. 

The following image gallery is created with CSS: 

The source code looks like this: 

<html> 

<head> 
<style type="text/css"> 

div.img 

  { 
  margin: 2px; 

  border: 1px solid #0000ff; 

  height: auto; 

  width: auto; 
  float: left; 

  text-align: center; 

  } 

div.img img 

  { 

  display: inline; 

  margin: 3px; 

  border: 1px solid #ffffff; 

  } 

div.img a:hover img 

  { 

  border: 1px solid #0000ff; 

  } 

div.desc 

  { 

  text-align: center; 
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  font-weight: normal; 

  width: 120px; 
  margin: 2px; 

  } 

</style> 

</head> 

<body> 

<div class="img"> 

  <a target="_blank" href="klematis_big.htm"> 
  <img src="klematis_small.jpg" alt="Klematis" width="110" 

  height="90" /> 

  </a> 

  <div class="desc">Add a description of the image here</div> 

</div> 

<div class="img"> 

  <a target="_blank" href="klematis2_big.htm"> 

  <img src="klematis2_small.jpg" alt="Klematis" width="110" 

  height="90" /> 

  </a> 
  <div class="desc">Add a description of the image here</div> 

</div> 

<div class="img"> 

  <a target="_blank" href="klematis3_big.htm"> 

  <img src="klematis3_small.jpg" alt="Klematis" width="110" 

  height="90" /> 

  </a> 
  <div class="desc">Add a description of the image here</div> 

</div> 

<div class="img"> 

  <a target="_blank" href="klematis4_big.htm"> 

  <img src="klematis4_small.jpg" alt="Klematis" width="110" 

  height="90" /> 

  </a> 

  <div class="desc">Add a description of the image here</div> 

</div> 

</body> 

</html> 

 

 
 
 

Execute the code and try creating one. 
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WEEK Ten (practical) 

Learning Outcome 

  
Students should know what script represent in html and how to use 

scripting  

 

 

Scripts offer authors a means to extend HTML documents in highly 

active and interactive ways. For example: 

• Scripts may be evaluated as a document loads to modify the 
contents of the document dynamically.  

• Scripts may accompany a form to process input as it is 

entered. Designers may dynamically fill out parts of a form 

based on the values of other fields. They may also ensure that 
input data conforms to predetermined ranges of values, that 

fields are mutually consistent, etc.  

• Scripts may be triggered by events that affect the document, 

such as loading, unloading, element focus, mouse movement, 

etc.  

• Scripts may be linked to form controls (e.g., buttons) to 

produce graphical user interface elements.  

 

Lab1: Write an UML code that opens a JavaScript alert as 
soon as the page loads. 

Practice 
The code is as below 

 
 
<script type="text/javascript"> 

 alert("I am a script. I ran first!") 
</script> 
 

Lab2: Write an UML code that opens a JavaScript alert as 

soon as page loads. 
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WEEK Eleven (practical) 

Learning Outcome 

  
Students should know how to develop and insert java scrip into an 

HTML page  

 

Lab1: Uses of JavaScript 

• JavaScript gives HTML designers a programming tool - 

HTML authors are normally not programmers, but JavaScript 

is a scripting language with a very simple syntax! Almost 

anyone can put small "snippets" of code into their HTML pages  

• JavaScript can put dynamic text into an HTML page - A 

JavaScript statement like this: document.write("<h1>" + 
name + "</h1>") can write a variable text into an HTML page  

• JavaScript can react to events - A JavaScript can be set to 

execute when something happens, like when a page has 
finished loading or when a user clicks on an HTML element  

• JavaScript can read and write HTML elements - A 

JavaScript can read and change the content of an HTML 

element  
• JavaScript can be used to validate data - A JavaScript can 

be used to validate form data before it is submitted to a 

server. This saves the server from extra processing  

• JavaScript can be used to detect the visitor's browser - 

A JavaScript can be used to detect the visitor's browser, and - 

depending on the browser - load another page specifically 

designed for that browser  

• JavaScript can be used to create cookies - A JavaScript 

can be used to store and retrieve information on the visitor's 

computer  

JavaScript Designs  

 

The HTML <script> tag is used to insert a JavaScript into an 

HTML page. 

Lab2:   Demonstrate JavaScript code in an HTML Page 
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Practice 
 

<html> 

<body> 

<script type="text/javascript"> 
document.write("Hello World!"); 

</script> 

</body> 

</html> 

The code above will produce this output on an HTML page: 

Hello World!  

 

Example Explained 

To insert a JavaScript into an HTML page, we use the <script> tag. 

Inside the <script> tag we use the type attribute to define the 
scripting language. 

So, the <script type="text/javascript"> and </script> tells where 

the JavaScript starts and ends: 

<html> 

<body> 

<script type="text/javascript"> 

... 

</script> 

</body> 

</html> 
 

Adding Strings and Numbers 

Look at these examples: 

x=5+5; 

document.write(x); 

 

x="5"+"5"; 

document.write(x); 

 

x=5+"5"; 
document.write(x); 

 

x="5"+5; 

document.write(x); 
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WEEK Twelve (practical) 

Learning Outcome 

  
Students should know what DHTML is and its application to web 

features  

 

DHTML in Short: 

DHTML is all about the ability of the browser to change look and 

style even after the document has loaded.  

 

The style object of IE 4 

HTML elements in IE 4 now all support a style object, which is 

essentially the "dynamic" object used to manipulate the look and 

"feel" of that element. Like the <layer> tag, elements can also be 
assigned an "id" attribute, which can then be used to identify it 

during scripting. For example:  

<div id="adiv"></div> 

In your script, the syntax required to access the style object of 

"adiv" would look like this: adiv.style  

Dynamic content in IE 4 

In IE 4, dynamic content is realized through a special property 

called innerHTML that exists on the <span> and <div> tag. Just set 

this property to a new HTML value, and the contents inside that 

span or div is instantly updated to the new value! I'll illustrate how 

it's done by modifying the above example to create dynamic 

content for IE 4 users:  

<div id="mydiv"></div> 
 

<script language="JavaScript1.2"> 

var thecontents=new Array() 

thecontents[0]="How are you today?" 

thecontents[1]="I am fine, thank you." 

thecontents[2]="Well, nice talking to you!" 

var current=0 

 

function changecontent() { 
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  mydiv.innerHTML=thecontents[current] 

  if (current==2) current=0 

  else current++ 

  setTimeout("changecontent()",3000) 

} 

 

window.onload=changecontent 

//-->lt;/script> 

How are you today? 

Moving elements in IE 4 

By the way, the day when NS and IE agree upon one 
implementation of DHTML is the day I can stop writing two versions 

of everything (just letting out a little frustration). Moving an 

element in IE 4 involves basically first wrapping that element either 

inside a positioned span or div, then changing the span or div's 

pixelLeft and pixelTop properties. It sounds complicated, but is 

actually very simple:  

 
 

<div id="spaceship" style="position:relative"> 

<img src="tn00018a.gif"> 

</div> 

 

<script><!-- 

function moving2() { 

  if (spaceship.style.pixelLeft<1000) 

    spaceship.style.pixelLeft+=5 

  moveid2=setTimeout("moving2()",50) 

} 

 

function come_back2() { 

  clearTimeout(moveid2) 

  spaceship.style.pixelLeft=0 

} 

//--></script> 

 

<form> 
<input type="button" value="Move" onClick="moving2()"> 

<input type="button" value="Come back" onClick="come_back2()"> 

</form> 
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WEEK Thirteen (practical) 

Learning Outcome 

  
Students should know how to insert multimedia element in web 

pages.  

 

Multimedia Formats 

Multimedia elements (like sounds or videos) are stored in media 

files. 

The most common way to discover the media type is to look at the 

file extension. 

When a browser sees the file extensions .htm or .html, it will 

assume that the file is an HTML page. The .xml extension indicates 

an XML file, and the .css extension indicates a style sheet.  

Picture formats are recognized by extensions like .gif and .jpg. 

Multimedia elements also have their own file formats with different 

extensions. 

 

Flash in HTML 

Lab1: Demonstrate Flash Embedding in HTML 

After creating a Flash movie you choose File > Save As from the top 

menu to save your movie. Save the file as "Somefilename.fla".  

To embed the Flash movie you just made into an HTML page, you 

should go back to your Flash program and do the following steps: 

Step 1 

Choose File > Open. Open a Flash movie you have created. 

Step 2 

Choose File > Export Movie. 

Step 3 

Name the file "somefilename.swf". Choose the location where the 
file is to be stored (in your Web folder). Click OK. 
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Step 4 
Open the HTML page where you want to insert your Flash movie. 

Insert this code: 

<object width="550" height="400"> 

<param name="movie" value="somefilename.swf"> 

<embed src="somefilename.swf" width="550" height="400"> 

</embed> 

</object> 

Note: This is the minimum code you need to embed a Flash movie 

in a browser. A broken icon will appear on the Web page if the user 
does not have the Flash plug-in installed. 

Note: In the code above there is both an <embed> tag and an 

<object> tag. This is because the <object> tag is recognized by 

Internet Explorer, and Netscape recognizes the <embed> tag and 

ignores the <object> tag. 

Step 5 

Type in the address of the HTML file in your browser and look at 
your first Flash movie. 

 

Let the Flash Program do the Work 

The code above is the absolute minimum code to embed Flash 

movies in HTML pages. It is not recommended to use the minimum 

code. There should be a few more attributes added: 

• classid is an attribute to the <object> tag. It tells Internet 
Explorer to load the ActiveX plug-in if it is not installed  

• pluginspage is an attribute to the <embed> tag. It displays a 

link to the Shockwave download page if Netscape does not 

have it   

The Flash program can add these attributes for you: 

Step 1 

Choose File > Publish. Flash will now create the <object>, 
<param>, and <embed> tags for you. It will also create the classid 

and pluginspage attributes. 

Step 2 

Open the HTML document that Flash created, view the HTML source 

and copy the code into your HTML page where you want your Flash 

movie. 
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Step 3 
Be sure that you have the "somefilename.swf" in your Web folder. 

Step 4 

Type in the address of the HTML file in your browser and look at 

your first Flash movie. 

Flash Tweening 

 

 

Tweening comes from the words "in between". 

With Tweening you can go from one keyframe to another and 

specify changes in the animation and let the Flash program 

create the frames in between. 

 

Example 

In this example you will learn how to make an object move across 

the screen. 

Step 1 

Create a small circle to the left in the Stage area. Do this by 

selecting the circle tool from the left toolbar. Draw the circle in the 

Stage area.  

Step 2 

Select the Arrow tool from the left toolbar. Double-click on the circle 

to select it.  

Step 3 

Now we have to convert the circle to a symbol. When the circle is 

converted to a symbol we can create instances of the circle. From 
the top menu choose Modify > Convert to Symbol. Name the 

symbol "Ball", and select OK.  

Step 4 

Go to Frame 10 in the Timeline. Do this by clicking the gray field 
below 10. Then right click in this field. Choose Insert Keyframe. 

Keyframes appear as circles in a frame. This operation duplicates 

the image.   

Note: A keyframe specifies changes in an animation. You create 

keyframes at important points in the Timeline and let Flash create 

the frames in between.  
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Step 5 
Select the circle and move it to the right a couple of inches.  

Step 6 

Click on the Timeline any place between Frame 1 and Frame 10. 

Then right click and choose Create Motion Tween.  

Step 7 

Choose Control > Test Movie from the top menu to test your Flash 

movie.  

Flash Guide Tweening 

 

 

With Motion Guide Tweening you can move an object from 

one location to another along a specified path. 

 

Example 

In this example you will learn how to draw a path an object should 

follow. 

Step 1 

Choose Window > Common Libraries > Graphics. Select the image 

you want to use. In this example we have used a blue mouse.  

Step 2 
Click on the image and drag it outside the left edge of the Stage.  

Step 3 

Go to Frame 40 in the Timeline. Do this by clicking the gray field 

below 40. Then right click in this field. Choose Insert Keyframe. 

Keyframes appear as circles in a frame. This operation duplicates 

the image.   

Step 4 
Click on the Timeline any place between Frame 1 and Frame 40. 

Then right click and choose Create Motion Tween.  

Step 5 

Right click on Layer 1 (Click on the layer name, where it says "Layer 

1"). Choose Add Motion Guide in the pop-up menu. The Flash 

program will now insert a motion guide layer on top of layer 1. 

Motion guide layers are used to draw lines an animated symbol 

should follow.  
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Step 6 
Click on the Motion Guide Layer to make sure it is the active layer 

(Click on the layer name, where it says "Guide: Layer 1").  

Step 7 

Click on the Pencil tool in the left toolbox. Set the Pencil Mode to 

Smooth (in the Options section of the left toolbox).  

Step 8 

Draw a line. Begin on the image and draw a line to the other side of 

the Stage.  

Step 9 

Go back to Frame 1 in the Timeline. Click on the Arrow tool in the 

left toolbox. Select the "Snap to Objects" button in the Options 

section of the left toolbox.  

Step 10 
Place the image with its center on the beginning of the motion guide 

(the black line you have drawn with the Pencil). The center of the 

image shows as a +. A black circle appears when the image is 

snapped to the motion guide. Release the mouse button when the 
image is snapped to the guide.  

Step 11 

Go to Frame 40. Place the image with its center on the end of the 
motion guide.  

Step 12 

Choose Control > Test Movie from the top menu to test your Flash 

movie.  

 

Is your Flash Movie Playing too Fast?  

You can control this by selecting Modify > Movie from the top menu. 

A Movie Properties box will show. The Frame Rate field sets how 

many frames to display per second. Adjust the number to a lower 

number, and test your movie again.  

Flash Tint Tweening 

 

 

With Tint Tweening you can change the color of an object. 
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Example 

In this example you will learn how to change the color of an object. 

Step 1 

Choose Insert > New Symbol.  

Note: To add Tint effects the object must be a symbol.  

Step 2 

Name the symbol "changecolor" and select the Graphic option in 

Behavior. Click OK.  

Note: You will now be taken to the symbol generator in the Flash 

program. Here you create symbols. Symbols can be dragged to the 

stage of your movie after you have created them.  

Step 3 

Choose the Text tool in the left toolbox. Choose Text > Size > 36 

from the top menu to make the text big. Choose Text > Style > 
Bold to make the text thick.  

Step 4 

Click in the work area and write "Color Changing Text".  

Step 5 

Jump back to the movie. Do this by choosing Edit > Edit Movie.  

Step 6 

Insert the symbol you just created into the movie. Choose Window 
> Library. Select the "changecolor" symbol and drag it into the 

middle of the Stage.  

Step 7 

Insert a keyframe in Frame 15 and in Frame 30.  

Step 8 

Go to Frame 15. Right click on the text in the Stage. In the pop-up 

menu, choose Panels > Effect.  

Step 9 

Choose Tint from the drop down menu. A color map will show. Set 

the colors to: R=0, G=255, B=0.  

Step 10 

Click on the Timeline any place between Frame 1 and Frame 15. 

Then right click and choose Create Motion Tween.  
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Step 11 
Click on the Timeline any place between Frame 15 and Frame 30. 

Then right click and choose Create Motion Tween.  

Step 12 

Choose Control > Test Movie from the top menu to test your Flash 

movie.  

Flash Shape Tweening 

 

 

With Shape Tweening you can change one object into 

another. 

 

Example 

In this example you will learn how to change one object into 
another. 

Example 

Step 1 

Choose the Text tool in the left toolbox. Choose Text > Size > 48 

from the top menu to make the text big. Choose Text > Style > 

Bold to make the text thick.  

Step 2 
Click in the work area and write "Hello".  

Step 3 

Right click on the text you just wrote and choose Panels > Align 

from the pop-up menu.  

Step 4 

In the Align box select the "To Stage" button first. Then click on the 

"Align Horizontal Center" button and the "Align Vertical Center" 
button. Close the Align box.  

Step 5 

Select the Arrow Tool and click on the text. Choose Modify > Break 

Apart from the top menu.  

Step 6 

Insert keyframes at Frame 24, 50 and 51.  
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Step 7 
Delete the text "Hello" in Frame 24. Select it and press the Delete 

button on your keyboard.  

Step 8 

Write a new text on the Stage. Write "World!" (Font size: 48, style: 

bold).  

Step 9 

Right click on the text you just wrote and choose Panels > Align 

from the pop-up menu. In the Align box select the "To Stage" 

button first. Then click on the "Align Horizontal Center" button and 

the "Align Vertical Center" button. Close the Align box  

Step 10 

Select the Arrow Tool and click on the text. Choose Modify > Break 

Apart from the top menu.  

Step 11 

Insert a keyframe in Frame 26.  

Step 12 

Double click the keyframe in Frame 1. In the small pop-up box click 

on the Frame tab. Set Tweening to Shape. Close the pop-up box.  

Step 13 

Double click the keyframe in Frame 26. In the small pop-up box 
click on the Frame tab. Set Tweening to Shape. Close the pop-up 

box.  

Step 14 

Double click the keyframe in Frame 51. In the large pop-up box 

click on the Frame Actions tab. Click on the + sign. Choose Basic 

Actions > Go To. Close the pop-up boxes.  

Step 15 
Choose Control > Test Movie from the top menu to test your Flash 

movie.  

Flash Button 1 

 

 

Example 

In this example you will learn how to insert an image, convert it to 

a button, and add a URL to it so it becomes a link. 
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Step 1 
Choose File > Import to import an image that will become a button. 

Locate the image and click Open. The image will be saved in the 

Library.  

Step 2 

Select the image with the Arrow tool.  

Step 3 

Convert the image to a symbol. Choose Insert > Convert to Symbol 

from the top menu. Name the symbol "button", choose Button from 

the Behavior list and click OK.  

Step 4 

Right click on the image. Choose Actions from the pop-up menu.  

Step 5 

In the Object Actions box click on the + sign. Choose Basic Actions 
> Get URL.  

Step 6 

Enter a full URL in the URL field (like http://www.w3schools.com).  

Step 7 

Choose target in the Window field. Close the Object Actions box.  

Step 8 

Choose Control > Test Movie from the top menu to test your Flash 

movie.  

Flash Button 2 

 

 

Example 

In this example you will learn how to create your own button and 

add a URL to it so it becomes a link. 

Step 1 

Choose Insert > New Symbol from the top menu.  

Step 2 

Name the symbol "button", choose Button from the Behavior list 

and click OK. In the Timeline area, you will now see the four states 

of a button: up, over, down, hit.  
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Step 3 
Select the Rectangle tool, pick a light red Fill Color and draw a 

rectangle in the work area.   

Step 4 

Select the Text tool, pick a dark Fill Color and write "Click Me" over 

the rectangle.   

Step 5 

Select the Arrow tool and place the text in the middle of the 

rectangle.   

Step 6 

Add a keyframe to the Over State in the Timeline. The Over State 

indicates what should happen when you mouse over the button.  

Step 7 

Select the Rectangle, change the Fill color to a light green.   

Step 8 

Choose Edit > Edit Movie to go back to the movie.  

Step 9 

Choose Window > Library to locate the button. Drag the button into 

the work area.   

Step 10 

Right click on the image. Choose Actions from the pop-up menu.  

Step 11 

In the Object Actions box click on the + sign. Choose Basic Actions 

> Get URL.  

Step 12 
Enter a full URL in the URL field (like http://www.w3schools.com).  

Step 13 

Choose target in the Window field. Close the Object Actions box.  

Step 14 

Choose Control > Test Movie from the top menu to test your Flash 

movie.  
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Flash Animation 

 

 

Example 

Step 1 

Insert a text in the upper left corner of the Stage area. Do this by 

selecting the text tool from the left toolbar. Write some text in the 
"textarea".  

Step 2 

Select the arrow tool from the left toolbar. Click on the text once to 

select it.  

Step 3 

Convert the text to a symbol. From the top menu choose Insert > 

Convert to Symbol. Name the symbol "text", choose graphic from 
the Behavior list and select OK.  

Step 4 

Go to Frame 30 in the Timeline. Do this by clicking the gray field 

below 30. Then right click in this field. Choose Insert Keyframe. 

Keyframes appear as circles in a frame.  

Step 5 

Click on the Timeline any place between Frame 1 and Frame 30. 

Then right click and choose Create Motion Tween.  

Step 6 

Go back to Frame 30 in the Timeline. Move the text to the lower 

right corner.  

Step 7 

Make sure the text is selected. Choose Modify > Transform > Flip 

Horizontal.  

Step 8 

Choose Control > Test Movie from the top menu to test your Flash 

movie. The text should move from the first location (in frame 1) to 

the second location (in frame 2). The text should also turn around 

on its way to the second location.  
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Flash Sound 

 

 

Example 

Step 1 

Choose File > Import to import a sound file. Locate the sound file 

and click Open. The sound file will be saved in the Library. 

Step 2 

Click in the first frame of "Layer 1" in the Timeline. Choose Window 
> Panels > Sound from the top menu. 

Step 3 

In the pop up window (Sound) choose the sound you imported in 

the Sound field. Choose Stream in the Sync field. Close the pop up 

window. 

Step 4 

Go to frame 50 in the Timeline. Right click and choose Insert 
Frame. 

Step 5 

Choose Control > Test Movie from the top menu to test your Flash 

movie. 
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WEEK Fourteen (practical) 

Learning Outcome 
  

Students should know how to use front page as a web development 

tool  
 

Introduction to FrontPage  
 

Using Page Templates 
 
• Use Windows Explorer to create a folder called FrontPage Foundation Work 

Folder in the My Documents folder. 
• Copy the Images folder from your Web design work to your FrontPage 

Foundation Work Folder 
• Launch FrontPage. 

 
Note: If the new_page_1.htm page and the New Page or Web task pane are 
opened, click the X at the top right corner to close them down: 
 

 
 

 
 

• From the Main Menu, choose File > New > Page or Web to open the New Page 
or Web task pane. 

• From the New from template section of the New Page or Web task pane, select 
the Page Templates command: 
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• From the General tab of the Page Templates dialog box, select the One-column 

Body with Two Sidebars template, and press the OK button: 
 

 
 

Toolbars 
 

Using the Save Button 
 
• From the Standard toolbar, click the Save button to save your page: 

 

 
 

• Navigate to the FrontPage 2002 Foundation Work Folder and save your page 
as Index.htm. 
 
Note: The Index.htm name should automatically appear in the File name field 
when you save the page. 
 

• Click the Save All button to display the Save Embedded Files dialog box:  
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Note: Any graphics that are not imported with the Insert Picture command will 
cause the Save Embedded Files dialog box to be displayed. 
 

• Click the Change Folder button to display the File Open dialog box. 
• Locate the FrontPage Work Folder\Images folder and click the Open button. 
• Leave the picture as a JPEG file and click the OK button. 

 
Note: If you check your FrontPage Foundation Work Folder you will notice 
two files have now been added: 
 

 
 

Text 
 

Editing Text 
 
• Triple click the Your Heading Goes Here title OR place the cursor at the end of 

the title and drag it back to the beginning to highlight the title: 
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• Rename the heading to read My First Web Page: 
 

 
 

 

Aligning Text 
 
• With the cursor still in the title, choose Format > Paragraph to display the 

Paragraph dialog box. 
• From the Indents and Spacing tab of the Paragraph dialog box, choose Center 

from the Alignment drop down list and click the OK button: 
 

 
 

 
 

• From Standard toolbar, click the Save button  
 
OR from the Menu toolbar, choose File > Save  
 
OR press the Ctrl + S key combination to save your work. 
 



PRACTICAL BOOK (WEB TECH. COM 225) 

 
 
 

Colors 
 
 

Changing the Page Properties 
 
• From the Main Menu, choose File > Properties to display the Page Properties 

dialog box. 
• Select the General tab and enter My First Web Page into the Title field: 

 

 
 

• While you are still in the General tab select the Background tab and check the 
Background Picture checkbox. 

• In the Formatting section, click the Browse button, and Open the orange 
texture.gif file from the Images Folder inside the FrontPage 2002 Foundation 
Samples folder: 
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• In the Colors section, use the drop-down menus to enter the following: 

 

 
 
Hyperlink - Navy 
Visited hyperlink - Green 
Active hyperlink - Red 
 

• Click the OK button to return to the page. 
• Triple click the My First Web Page title OR place the cursor at the end of the 

title and drag it back to the beginning to highlight the title: 
 

 
 

• From the Formatting toolbar, click Font Color button to reveal the drop down 
menu and select the Navy color swatch:  
 

 
 

 
 

• From Standard toolbar, click the Save button  
 
OR from the Menu toolbar, choose File > Save  
 
OR press the Ctrl + S key combination to save your work. 
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WEEK Fifteen (practical) 

Learning Outcome 

  

Students should be able to xml package ND APPLY TO A GIVEN 

CASE  
 

Lab1:What Does XML Do? 

Maybe it is a little hard to understand, but XML does not DO 
anything. XML was created to structure, store, and transport 

information. 

The following example is a note to Tove from Jani, stored as XML: 

<note> 

<to>Tove</to> 

<from>Jani</from> 

<heading>Reminder</heading> 

<body>Don't forget me this weekend!</body> 

</note> 

The note above is quite self descriptive. It has sender and receiver 

information, it also has a heading and a message body. 

But still, this XML document does not DO anything. It is just pure 
information wrapped in tags. Someone must write a piece of 

software to send, receive or display it. 
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The image above represents one book in the XML below: 

<bookstore> 

<book category="COOKING"> 
  <title lang="en">Everyday Italian</title>  

  <author>Giada De Laurentiis</author>  

  <year>2005</year>  

  <price>30.00</price>  
</book> 

<book category="CHILDREN"> 

  <title lang="en">Harry Potter</title>  

  <author>J K. Rowling</author>  

  <year>2005</year>  

  <price>29.99</price>  

</book> 

<book category="WEB"> 

  <title lang="en">Learning XML</title>  

  <author>Erik T. Ray</author>  

  <year>2003</year>  

  <price>39.95</price>  

</book> 
</bookstore> 

XML Elements are Extensible 

XML elements can be extended to carry more information. 

Look at the following XML example: 

<note> 

<to>Tove</to> 

<from>Jani</from> 
<body>Don't forget me this weekend!</body> 

</note> 

Let's imagine that we created an application that extracted the <to>, <from>, and 
<body> elements from the XML document to produce this output: 

MESSAGE  

To: Tove 
From: Jani 

Don't forget me this weekend! 

Imagine that the author of the XML document added some extra information to it: 



PRACTICAL BOOK (WEB TECH. COM 225) 

 

 
58 

<note> 

<date>2008-01-10</date> 
<to>Tove</to> 

<from>Jani</from> 

<heading>Reminder</heading> 

<body>Don't forget me this weekend!</body> 

</note> 

Should the application break or crash? 

No. The application should still be able to find the <to>, <from>, and <body> 
elements in the XML document and produce the same output. 

One of the beauties of XML, is that it can often be extended without breaking 
applications. 
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